0 komentar

Cara Install Modem Smartfren CE682 di Ubuntu

3/30/2012 09:13:00 AM
"Selamat datang di blog saya :)
ini postingan pertama saya... hhe
Tadi barusan saya install ubuntu 11.10 di laptop saya, setelah install OSnya langsung kepiran gmna agar modem Smartfreen CE682 saya bisa konek di Ubuntu 11.10 ini, setelah googling akhirnya dapat juga tutorialnya :D



Nah! kali ini saya akan berbagi tutorialnya kepada anda :)
oke langsung aja...


Pertama colokin modem smartfreen, trus buka Terminal dan masukan perintah
eggo@projects:~$ dmesg | tail
perintah diatas untuk mencari tau apakah modem sudah kedetect atau belom! dan ternyata modemnya belom kedetect dan masih dikenali sebagai CD ROM
eggo@projects:~$ dmesg | tail
[ 16.435959] ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 19.963390] EXT4-fs (sda7): re-mounted. Opts: errors=remount-ro,commit=0
[ 19.966436] EXT4-fs (sda8): re-mounted. Opts: commit=0
[ 241.704054] usb 2-2: USB disconnect, address 3
[ 253.352033] usb 2-2: new full speed USB device using uhci_hcd and address 4
[ 253.522675] scsi5 : usb-storage 2-2:1.0
[ 254.524252] scsi 5:0:0:0: CD-ROM CDROM EVDO ReV A 7.00 PQ: 0 ANSI: 2
[ 254.536216] sr1: scsi-1 drive
[ 254.536454] sr 5:0:0:0: Attached scsi CD-ROM sr1
[ 254.536652] sr 5:0:0:0: Attached scsi generic sg2 type 5
 agar modemnya kedetect maka eject dulu CDROM nya! masukan perintah :
eggo@projects:~$ sudo eject /dev/sr1
nah sekarang coba liat lagi apakah modem sudah dikenali or belom :D
masukan lagi perintah "dmesg"
eggo@projects:~$ dmesg | tail
[ 254.524252] scsi 5:0:0:0: CD-ROM CDROM EVDO ReV A 7.00 PQ: 0 ANSI: 2
[ 254.536216] sr1: scsi-1 drive
[ 254.536454] sr 5:0:0:0: Attached scsi CD-ROM sr1
[ 254.536652] sr 5:0:0:0: Attached scsi generic sg2 type 5
[ 365.648085] usb 2-2: USB disconnect, address 4
[ 368.192038] usb 2-2: new full speed USB device using uhci_hcd and address 5
[ 368.375134] scsi6 : usb-storage 2-2:1.3
[ 369.380301] scsi 6:0:0:0: Direct-Access SDVDISK EVDO ReV A 7.00 PQ: 0 ANSI: 0 CCS
[ 369.381257] sd 6:0:0:0: Attached scsi generic sg2 type 0
[ 369.473277] sd 6:0:0:0: [sdb] Attached SCSI removable disk
nah sekarang modemnya sudah kedetect :)
selanjutnya cek modem dengan perintah "lsusb"
eggo@projects:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 04f2:b1d8 Chicony Electronics Co., Ltd
Bus 002 Device 006: ID 0489:e010 Foxconn / Hon Hai
Bus 002 Device 005: ID 201e:1022
diatas terlihat modem terdetect dengan id product "Bus 002 Device 005: ID 201e:1022" tapi nama vendornya gak kedetect! ? ini gak jadi masalah.. hhe
lanjut saja edit "usb_modeswitch.conf" nya...
eggo@projects:~$ sudo gedit /etc/usb_modeswitch.conf
masukan kode dibawah ini pada baris terakhir
########################################################
# /etc/usb_modeswitch.conf
#
# Smart Haier CE682 (EVDO)
#
DefaultVendor = 0x201e
DefaultProduct = 0×1022

TargetProduct = 0×1022
TargetVendor = 00x201e
MessageContent=”5553424312345678c00000008000069f030000000000000000000000000000″
Save, kemudian masuk lagi ke
eggo@geeks:~$ sudo gedit /etc/udev/rules.d/99-haier-ce682.rules
isi dengan :
########################################################
# /etc/udev/rules.d/99-zte-ce682.rules
#
# Smart Haier CE682 (EVDO)
#
SUBSYSTEM==”usb”, SYSFS{idVendor}==”201e”,
SYSFS{idProduct}==”1022″, RUN+=”/usr/sbin/usb_modeswitch –default-vendor 0x201e –default-product 0×1022 –message-content 5553424312345678c00000008000069f030000000000000000000000000000″
save, kemudian load beberapa parameter yang dibutuhkan oleh kernel
eggo@geeks:~$ sudo modprobe usbserial vendor=0X201e product=0X1022
nah, sampai disini, sekarang install wvdial, wvdial adalah Point-to-Point Protocol dialer (pppd) untuk menghubungkan ke Internet. ketikan perintah install
eggo@geeks:~$ sudo apt-get install wvdial
 sekarang deteksi modemnya dengan wvdial :)
eggo@geeks:~$ sudo wvdialconf
Editing `/etc/wvdial.conf’.
Scanning your serial ports for a modem.
ttyS0: ATQ0 V1 E1 — failed with 2400 baud, next try: 9600 baud
ttyS0: ATQ0 V1 E1 — failed with 9600 baud, next try: 115200 baud
ttyS0: ATQ0 V1 E1 — and failed too at 115200, giving up.
ttyS1: ATQ0 V1 E1 — failed with 2400 baud, next try: 9600 baud
ttyS1: ATQ0 V1 E1 — failed with 9600 baud, next try: 115200 baud
ttyS1: ATQ0 V1 E1 — and failed too at 115200, giving up.
Modem Port Scan: S2 S3 S4 S5 S6 S7 S8 S9
Modem Port Scan: S10 S11 S12 S13 S14 S15 S16 S17
Modem Port Scan: S18 S19 S20 S21 S22 S23 S24 S25
Modem Port Scan: S26 S27 S28 S29 S30 S31
WvModem: Cannot get information for serial port.
ttyUSB0: ATQ0 V1 E1 — OK
ttyUSB0: ATQ0 V1 E1 Z — OK
ttyUSB0: ATQ0 V1 E1 S0=0 — OK
ttyUSB0: ATQ0 V1 E1 S0=0 &C1 — OK
ttyUSB0: ATQ0 V1 E1 S0=0 &C1 &D2 — OK
ttyUSB0: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK
ttyUSB0: Modem Identifier: ATI — Manufacturer: +GMI: China TeleCom
ttyUSB0: Speed 9600: AT — OK
ttyUSB0: Max speed is 9600; that should be safe.
ttyUSB0: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK
WvModem: Cannot get information for serial port.
ttyUSB1: ATQ0 V1 E1 — failed with 2400 baud, next try: 9600 baud
ttyUSB1: ATQ0 V1 E1 — failed with 9600 baud, next try: 9600 baud
ttyUSB1: ATQ0 V1 E1 — and failed too at 115200, giving up.
WvModem: Cannot get information for serial port.
ttyUSB2: ATQ0 V1 E1 — OK
ttyUSB2: ATQ0 V1 E1 Z — OK
ttyUSB2: ATQ0 V1 E1 S0=0 — OK
ttyUSB2: ATQ0 V1 E1 S0=0 &C1 — OK
ttyUSB2: ATQ0 V1 E1 S0=0 &C1 &D2 — OK
ttyUSB2: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK
ttyUSB2: Modem Identifier: ATI — Manufacturer: +GMI: China TeleCom
ttyUSB2: Speed 9600: AT — OK
ttyUSB2: Max speed is 9600; that should be safe.
ttyUSB2: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 — OK
Found a modem on /dev/ttyUSB0.
Modem configuration written to /etc/wvdial.conf.
ttyUSB0: Speed 9600; init “ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0″
ttyUSB2: Speed 9600; init “ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0″

ternyata modem kedetect di "/dev/ttyUSB0"
oke...sekarang lanjut edit pengaturan "wvdialconf"
eggo@geeks:~$ sudo gedit /etc/wvdial.conf
isi dengan :
[Dialer smart]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Stupid Mode = 1
Modem Type = Analog Modem
Command Line = ATDT
ISDN = 0
New PPPD = yes
Phone = #777
Modem = /dev/ttyUSB0
Username = smart
Password = smart
Baud = 460800
save, kemudian cobalah konek dengan perintah "wvdial smart"
eggo@geeks:~$ sudo wvdial smart
--> WvDial: Internet dialer version 1.61
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
AT+GCAPAT+GCAP
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT#777
--> Waiting for carrier.
CONNECT 3100000
--> Carrier detected.  Starting PPP immediately.
--> Starting pppd at Sat Mar 31 03:22:15 2012
--> Pid of pppd: 2791
--> Using interface ppp0
--> local  IP address 10.231.238.176
--> remote IP address 10.20.31.25
---> primary   DNS address 10.17.3.252
--> secondary DNS address 10.17.3.246
Nah! klo IP address dan DNS address nya udah muncul, itu berarti sudah terhubung ke Internet, cobalah ping ke google atau langsung buka browser anda kemudian browsing ke google...


oke! semoga tutorial ini bermanfaat :)
Posting Lebih Baru
Previous
This is the last post.

0 komentar:

Poskan Komentar

 
Toggle Footer
Top